Печать фискального чека WebCheck для 1с7.7 ТиС, Бух

Публикация № 1581151 10.01.22

Бухгалтерский учет - Кассовые операции

обработка вебчек webchek

Доработанный пример обработки для печати фискального чека для 1с7.7 ТиС, Бух. Возможности обработки: Открытие кассовой смены (автоматически предлагается сделать служебный внос). Регистрация продаж. X-отчет. Z-отчет (перед закрытием смены проверяется сумма наличных, предлагается сделать служебный вынос). Проверить текущий статус фискального регистратора. Печать последнего чека, последнего Z-отчета.

Доработан пример обработки для 77, оригинальная обработка Вебчек

Проверялась на ТиС (7.70.013), Бух (7.70.286), платформа 7.70.027.

Обработку загрузить в конфигурацию с именем "ВебЧекПРРО".

Для вызова обработки можно добавить в пункт меню


Возможности обработки:

  • Открытие кассовой смены (автоматически предлагается сделать служебный внос)
  • Регистрация продаж (кнопка на форме документа, см. дальше)
  • X-отчет
  • Z-отчет (перед закрытием смены проверяется сумма наличных, предлагается сделать служебный вынос)
  • Проверить текущий статус фискального регистратора
  • Печать последнего чека, последнего Z-отчета.

 


Для работы в конфигурацию нужно добавить справочник "ФискальныеРегистраторы" с двумя реквизитами:
 - "ИДУстройства", Строка, 10
 - "ИдКассира", Строка, 10
В справочник "Пользователи" добавить реквизит "ФискальныйРегистратор", Тип "Спавочник.ФискальныеРегистраторы"
Пользователю, работающему с ФР заполнить данные.




В глобальный модуль добавить процедуры, вызываемые кнопкой на форме документов:
 

//======================================================================
Процедура глОтправитьДокументНаФискальныйРегистратор(Конт, ФискальныйНомер = "", СсылкаДФС = "") Экспорт
	
	СпПарам = СоздатьОбъект("СписокЗначений");
	СпПарам.ДобавитьЗначение(Конт.ТекущийДокумент(), "Документ");
	
	ОткрытьФормуМодально("Обработка.ВебЧекПРРО", СпПарам);
	
	Попытка
		// устанавливаю возвращенные значения
		Конт.ФискальныйНомерЧека = СпПарам.Получить("ФискальныйНомерЧека");
		Конт.ЧекСсылкаДФС 		= СпПарам.Получить("ЧекСсылкаДФС");
	Исключение
	КонецПопытки;
	
	
КонецПроцедуры // глОтправитьДокументНаФискальныйРегистратор

//======================================================================
Процедура глПечатьДокументаНаФР(Конт) Экспорт
	
	Если Конт = 0 Тогда
		Конт = СоздатьОбъект("Документ.РасходнаяНакладная");
	КонецЕсли;
	
	Если (Конт.ТекущийДокумент().Проведен() = 0) или (Конт.Модифицированность() = 1) Тогда
		Предупреждение("Документ должен быть записан и проведен", 10);
		Возврат;
	КонецЕсли;
	
	Если ПустаяСтрока(Конт.ФискальныйНомерЧека) = 0 Тогда
		Предупреждение("Документ уже зарегистрирован в ДФС", 10);
		Возврат;
	КонецЕсли;
	
	ФискальныйНомер = "";
	СсылкаДФС 		= "";
	
	глОтправитьДокументНаФискальныйРегистратор(Конт);
	
КонецПроцедуры // ПечатьДокументаНаФР

//======================================================================
Функция глДоступностьКнопкиЧекККМ(Конт) Экспорт
	
	Возврат Пользователь.ФискальныйРегистратор.Выбран() * Конт.Выбран() * (1 - Конт.Модифицированность());
	
КонецФункции // глДоступностьКнопкиЧекККМ

В конфигурации Бухгалтерия также добавить в глобальный модуль еще 2 функции:

 

// ===============================
Функция глЕстьРеквизитШапки(ИмяРеквизита, ВидДокумента) Экспорт
	Перем Реквизит;
	Если (ПустоеЗначение(ВидДокумента) = 1) ИЛИ
	     (ПустоеЗначение(ИмяРеквизита) = 1) Тогда
		Возврат Нет;
	КонецЕсли;
	Реквизит=Метаданные.Документ(ВидДокумента).РеквизитШапки(ИмяРеквизита);
	Возврат ?(Реквизит.Выбран()=1, Да, Нет );
КонецФункции

// ===============================
Функция глЕстьРеквизитМнЧ(ИмяРеквизита,ВидДокумента) Экспорт
	Перем Реквизит;    // 
	Если (ПустоеЗначение(ВидДокумента) = 1) ИЛИ
	     (ПустоеЗначение(ИмяРеквизита) = 1) Тогда
		Возврат Нет;
	КонецЕсли;
	Реквизит=Метаданные.Документ(ВидДокумента).РеквизитТабличнойЧасти(ИмяРеквизита);
	Возврат ?(Реквизит.Выбран()=1, Да, Нет );
КонецФункции

В документы РасходнаяНакладная, ПриходнаяНакладная (для бухгалтерии - ВозвратнаяНакладная) добавить реквизиты шапки:
 - "ЧекСсылкаДФС" - "Строка", 256
 - "ФискальныйНомерЧека" - Строка, 20

При желании вывести реквизиты на форму документа, запретить редактирование

Для печати фискального чека на формы документов РасходнаяНакладная, ПриходнаяНакладная (для бухгалтерии - ВозвратнаяНакладная) добавить кнопку с именем "кнЧекККМ" и формулой "глПечатьДокументаНаФР(Контекст)". 




 

По нажатию кнопки происходит фискализация чека на портале ДФС.



 

В функцию "УстДоступность" модуля формы документов добавить строку (кнопка будет доступна тем пользователям, у которых выбран ФискальныйРегистратор в справочнике "Пользователи", см. выше):
 

Форма.кнЧекККМ.Доступность(глДоступностьКнопкиЧекККМ(Контекст));


Установить, настроить сервер webchek, можно работать.

По результатам тестирования: Сервис Webchek показал более стабильную работу по сравнению с другими (Кашалот, чекбокс, Вчасно.каса). Простая интеграция, простая настройка сервера webchek, быстрая реакция техподдержки по любым вопросам.

На момент написания публикации обработка проработала на указанных конфигурациях порядка двух недель, проблем пока не выявлено.

Скачать файлы

Наименование Файл Версия Размер
Обработка печати фискального чека WebCheck для 1с77 ТиС, Бух:

.ert 44,50Kb
3
.ert 44,50Kb 3 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Выгрузка товаров из 1С:Предприятия 7.7 "Торговля и Склад 9.2" в файл CSV для онлайн кассы МТС

Кассовые операции Оптовая торговля Розничная торговля Загрузка и выгрузка в Excel v77::ОУ 1С7:ТиС БУ УУ Абонемент ($m)

Данная обработка предназначена для выгрузки файла из программы 1С: Предприятие 7.7 Конфигурации «Торговля и Склад 9.2» в файл CSV для загрузки в кассу МТС. Тестирование проводилось на релизах 937 и 998. В теории должна работать на всех типовых релизах конфигурации «Торговля и Склад 9.2».

1 стартмани

07.02.2021    4212    1    Kuzya_brаtsk    1    

Загрузка товаров в ККТ "Меркурий" из 1С:Торговля и склад 9.2

Кассовые операции Розничная торговля ККМ v77::ОУ 1С7:ТиС Розничная и сетевая торговля (FMCG) Россия БУ УУ Абонемент ($m)

Обработка для загрузки базы кодов цен в ККТ "Меркурий" с помощью программы-конфигуратора MercConfig из базы Торговля и склад 9.2 1С: Предприятие 7.7.

1 стартмани

25.01.2021    4533    1    aleksandr_leiman    0    

Взаимодействие с ТАКСКОМ API 2.8 из 1с7.7

WEB Кассовые операции Розничная торговля v7.7 1cv7.md Россия УУ Абонемент ($m)

Взаимодействие с ТАКСКОМ через API 2.8 из 1с7.7. Получение Кассовых смен.

2 стартмани

06.10.2020    4381    5    serpent    0    

Выставление счета ссылкой на оплату через платежный шлюз Сбербанка из интерфейса 1С

Банковские операции Кассовые операции Оптовая торговля Розничная торговля v7.7 v8 1cv8.cf 1cv7.md Россия Абонемент ($m)

Внешняя обработка для выбора документа и формирования ссылки на оплату, которую можно скопировать в буфер обмена и отправить любыми средствами. Решение позволяет повысить автоматизацию процесса выставления счетов на оплату через интерфейс 1С8.х, 1С7.7. Совместимо с интернет-эквайрингом Сбербанк.

1 стартмани

14.01.2020    26986    131    etmarket    53    

1С 7.7: Обработка для печати чеков на ККМ ШТРИХ формата ФДД 1.05

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v7.7 1cv7.md Россия БУ Абонемент ($m)

Обработка позволяет печатать чеки формата ФДД 1.05 на кассовом аппарате ШТРИХ. Проверялась на версиях драйвера 4.14.721 - 749.

1 стартмани

03.04.2019    10187    10    user872794    1    

Загрузка в 1С 7.7 УСН 1.3 и БУХ 4.5 и Предприниматель 1.2 данных из ОФД о денежных поступлениях (чеках)

Обработка документов Загрузка и выгрузка в Excel Кассовые операции Кассовые операции v77::БУ 1С7:Бух Россия БУ Абонемент ($m)

Если Ваша торговая точка (ККМ) отделена от 1С 7.7 УСН, а вносить поступление наличных за день в 1С:Бухгалтерию надо, то автоматизировать процесс оформления наличных в 1С:Бухгалтерию можно!

2 стартмани

02.12.2017    16105    9    AlexHelmer    2    

Групповая печать ПКО и РКО для 1С:Бухгалтерии 7.7

Пакетная печать Кассовые операции Печатные формы Кассовые операции v77::БУ 1С7:Бух БУ Абонемент ($m)

Обработка групповой печати ПКО и РКО в 7.7 (2 шт. на одном листе).

1 стартмани

08.11.2017    12796    2    Юлия69    0    

Обработка подключения онлайн-кассы к 1С 7.7 (ПОЛУФАБРИКАТ)

ККМ Кассовые операции Кассовые операции v7.7 1С7:Бух Россия БУ Абонемент ($m)

Обработка обслуживания торгового оборудования для печати чеков ККМ. Протестирована на Конфигурации бухгалтерский учет (7.70.634) с кассой АТОЛ 30 Ф, Печать ПКО и РКО. Также работает на Торговля + Склад.

2 стартмани

31.05.2017    43570    112    Di_Denis    46    

Печать штрих-кодов из 1С: 7.7 Комплексная конфигурация

Рабочее место Кассовые операции Кассовые операции Печатные формы v7.7 1С7:Комплекс 1С7:ТиС Абонемент ($m)

Для тех кто работает на 7 платформе, и не собирается с неё переходить. Стандартная печать этикеток по одной шт за раз совсем даже не интересна. Мне при внедрении штрих кодирования мне помогла обработка

1 стартмани

21.06.2016    28243    7    agent00mouse    7    

Рабочее место кассира

Рабочее место Кассовые операции Розничная торговля Кассовые операции Розничная торговля v77::ОУ 1С7:ТиС Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Уникальная внешняя обработка "Рабочее место кассира" для конфигурации Торговля и склад.

3 стартмани

16.09.2015    18665    17    PitMal    3    

Обработка для 1С ТиС 9.2 для работы с ККМ Offline под РМК Штрих-М Кассир 1.*\2.*\5.*

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Обработки предназначены для 1С: Предприятие 7.7 типовой конфигурации Торговля и Склад 9.2. Сделано несколько существенных изменений по отношению к стандартной обработке Off_spos. И доработана обработка "Загрузка ККМ Off-Line".

1 стартмани

28.08.2015    32462    35        4    

Изменение банковского счета в документах - 1С Бухгалтерия 7.7

Обработка документов Банковские операции Кассовые операции Банковские операции Кассовые операции v77::БУ 1С7:Бух Россия БУ Абонемент ($m)

Иногда случается, что в справочнике дублируются записи. Это легко поправимо, если дублирующая запись не была использована в документах. В противном случае надо вручную выбирать во всех документах нужный элемент. А если количество документов тысячи - уйдет уйма времени... Данная обработка решает эту проблему! Просто выбрать старый счет (который планируем заменить) и новый (на который заменяем). Полезно.

1 стартмани

02.04.2015    11719    0    program345    9    

Обработка автоматической разноски денег по Кассе\Банку для сетевых (и не только) контрагентов для ТиС 7.7

Обработка документов Банковские операции Кассовые операции Рабочее место Банковские операции Кассовые операции v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Обработка позволяет в несколько кликов разнести деньги (касса или банковская выписка) по контрагенту, папке контрагентов либо по сетевому контрагенту (анализ по ИНН). Предварительно формируется список долговых документов с указанием суммы долга.

1 стартмани

11.06.2013    13371    20    iDim    2    

Перенумерация Приходных Ордеров

Обработка документов Кассовые операции Кассовые операции v7.7 1cv7.md Россия БУ Абонемент ($m)

Перенумерует все приходных ордера.

1 стартмани

22.10.2012    5582    18    BloodElf    1    

Универсальный групповой приход по кассе

Обработка документов Кассовые операции Кассовые операции v77::БУ 1С7:Бух Россия БУ Абонемент ($m)

Данная обработка создана для облегчения ввода документа Приходный кассовый ордер (УСН и Бухгалтерия 7.7.)

1 стартмани

01.09.2012    10702    11    malev    4    

Перенумератор кассовых ордеров

Обработка документов Кассовые операции Кассовые операции v77::БУ 1С7:Бух Россия Абонемент ($m)

Перенумерация кассовых ордеров

1 стартмани

06.04.2012    2934    21    toshibav    3    

Выгрузка в СЭД казначейства заявок на кассовый расход и заявок на возврат для релиза 647

Кассовые операции Внешние источники данных Кассовые операции v77::БУ 1С7:ББУ Россия БУ Госбюджет Абонемент ($m)

С 2012 года стали бюджетным учреждением. Пришлось в срочном порядке допиливать выгрузку в СЭД казначейства заявок на кассовый расход и заявок на возврат для релиза 647, может быть кому-то пригодиться.

1 стартмани

26.01.2012    19655    89    xxx90    25    

Регистрация бюджетных обязательств по кассовому расходу для ББУ 7.7

Обработка документов Кассовые операции Кассовые операции v77::БУ 1С7:ББУ Россия Госбюджет Абонемент ($m)

Регистрация бюджетных обязательств по кассовому расходу. Когда нужно срочно - а вовремя не сделано.

1 стартмани

19.10.2011    8061    18    strig_85    2    

Перенумерация приходных и расходных кассовых ордеров

Обработка документов Кассовые операции Кассовые операции v77::ОУ 1С7:Комплекс Абонемент ($m)

Каждый бухгалтер сталкивался с проблемой нумерации приходных и расходных кассовых ордеров. После удаления одного документа приходится менять номера оставшихся. Данная обработка облегчит эту задачу.

1 стартмани

10.10.2011    14049    51    SergeyCV76    8    

Проверка наличной оплаты

Обработка документов Анализ учета Взаиморасчеты Кассовые операции Взаиморасчеты Кассовые операции v77::ОУ 1С7:ТиС Абонемент ($m)

Проверка привязки ПКО к документу реализации в ТИС.

1 стартмани

21.09.2011    8211    16    discorat    1    

Поместить документы в конец дня (1С++, vfpoledb)

Обработка документов Файловые протоколы обмена, FTP Кассовые операции Кассовые операции v77::ОУ v77::БУ v77::Расчет 1С7:Бух 1С7:Комплекс 1С7:ТиС Абонемент ($m)

Обработка сдвигает документы ПКО в конец дня, причем располагает их в порядке возрастания номеров.

1 стартмани

17.09.2010    13316    66    nicxxx    10    

Акт о проверке наличных денежных средств кассы, разработанный для ТиС 9.2

Обработка документов Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Россия БУ Абонемент ($m)

Очень простой документ, делался по требованиям заказчика, по документу формируется унифицированная печатная форма № КМ-9.

1 стартмани

08.08.2010    15241    61    madonov    3    

Групповая печать ПКО для "Предприниматель" 7.7 с перенумерацией ПКО и РКО

Обработка документов Пакетная печать Печатные формы Кассовые операции Кассовые операции v77::ОУ 1cv7.md Россия БУ Абонемент ($m)

Обработку выкладываю для тех, кому нужно прямо сейчас и писать некогда. Особо ничего нового - но для Предпринимателя 7.7 ее вроде не было - я быстро не нашел

1 стартмани

25.05.2010    7129    67    melnikov_tkf    2    

Перенумерование ПКО и РКО для 1С: 7.7 Бухгалтерия, УСН, Предприниматель

Обработка документов Кассовые операции Кассовые операции v7.7 1С7:Бух Абонемент ($m)

Обработка перенумеровывает по порядку все ПКО и РКО с начала года по заданную дату

1 стартмани

17.07.2009    6537    51    flashfire    3    

Автоинкассация

Обработка документов Кассовые операции Кассовые операции v77::БУ 1С7:Бух Россия БУ Абонемент ($m)

Для тех, у кого каждый день в кассе должен оставаться минимум.

1 стартмани

06.05.2009    9715    18    serguson    4    

Подстановка паспортных данных в расходные кассовые ордера за период

Обработка документов Кассовые операции Кассовые операции v77::ОУ 1С7:ЗиК Россия БУ Абонемент ($m)

Часто выписываются расходники сотрудникам, у которых в справочнике еще не забиты паспортные данные. Но по правилам кассовой дисциплины они должны быть обязательно указаны. Позже эти данные заносятся в карточки сотрудников и, чтобы не изменять вручную значения пасп. данных в расходные кассовые ордера, была для автоматизации написана данная обработка. Протестировано на типовой конфигурации "Бухг. учет"

1 стартмани

12.11.2007    10301    209    martin1    1